<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Addiction, and Trauma, and Recovery | Recovery Rocks</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://recoveryrocks.bdnblogs.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/js/html5.js"></script>
	<![endif]-->
		<script>
		dataLayer = [{"event":"dataLayer-loaded","companyName":"Bangor Daily News","contentType":"home","author":"Jim LaPierre","contentPublishedDate":"2020-12-23","contentPublishedTime":"2020-12-23 07:56:36-05:00","lastUpdatedTime":"2020-12-23 07:56:36-05:00","primaryCategory":"Addiction","allCategories":"Addiction","visitorIP":"107.23.218.4, 64.252.69.192,10.0.12.238","wordCount":3676}];
	</script>
<script>
	var gtmSetupOptions = {"tagManagerId":"GTM-W3QLSF","autoRun":true};
</script><link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//recoveryrocks.bdnblogs.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//bdn-data.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="Recovery Rocks &raquo; Feed" href="https://recoveryrocks.bdnblogs.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Recovery Rocks &raquo; Comments Feed" href="https://recoveryrocks.bdnblogs.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Recovery Rocks &raquo; Addiction, and Trauma, and Recovery Comments Feed" href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/recoveryrocks.bdnblogs.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://recoveryrocks.bdnblogs.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-email-css'  href='https://recoveryrocks.bdnblogs.com/wp-content/plugins/wp-email/email-css.css?ver=2.67.5' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:300,400,700,300italic,400italic,700italic|Roboto+Slab:400italic,700italic,400,700' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://recoveryrocks.bdnblogs.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='bdnblog2013-style-css'  href='https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/style.css?ver=2016-10-24' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://recoveryrocks.bdnblogs.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.9' type='text/css' media='all' />
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-content/plugins/GTM-DataLayer/assets/js/gtm.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='https://recoveryrocks.bdnblogs.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://recoveryrocks.bdnblogs.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://recoveryrocks.bdnblogs.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Coping with powerlessness' href='https://recoveryrocks.bdnblogs.com/2020/12/07/addiction/coping-with-powerlessness/' />
<link rel='next' title='Hypervigilance and addiction recovery' href='https://recoveryrocks.bdnblogs.com/2021/01/07/addiction/hypervigilance-and-addiction-recovery/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" />
<link rel='shortlink' href='https://wp.me/p2gOiX-1hs' />
<link rel="alternate" type="application/json+oembed" href="https://recoveryrocks.bdnblogs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frecoveryrocks.bdnblogs.com%2F2020%2F12%2F23%2Faddiction%2Faddiction-and-trauma-and-recovery%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://recoveryrocks.bdnblogs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frecoveryrocks.bdnblogs.com%2F2020%2F12%2F23%2Faddiction%2Faddiction-and-trauma-and-recovery%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>        
	<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-51c20b68617564b1" data-minify="no" ></script>
	<script type="text/javascript">	    
        var addthis_config = {
            data_ga_tracker:'UA-5329647-48',
            data_track_addressbar:false
	    }; 
	    var addthis_share = {
            url: 'https://wp.me/p2gOiX-1hs',
            title: 'Addiction, and Trauma, and Recovery',
            templates: {
                twitter: '{{title}}: {{url}} (via @JimLaPierre)',
            }
	    };
        
        addthis.layers({
            'theme' : 'transparent',
                'share' : {
                  'position' : 'left',
                  'numPreferredServices' : 4,
                  'services' : "facebook,twitter,pinterest,email,more",
                'postShareFollowMsg' : "Follow Recovery Rocks:",
                  'offset' : {'top' : '320px'}
                }, 
            'follow' : {
              'services' : [
            {'service': 'facebook', 'id': 'healingandovercoming'},
            {'service': 'twitter', 'id': 'JimLaPierre'},
            {'service': 'rss', 'id': 'https://recoveryrocks.bdnblogs.com/feed/'}
              ],
              'offset' : {'top': '30px'}
            },  
            'whatsnext' : {} 
	  });
	  

	</script>
	<!-- AddThis Smart Layers END -->
    
    <!-- Please call pinit.js only once per page -->
    <!--I'm putting this here so it's only called once-->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>
    
    
    <script type="text/javascript">
        var googletag = googletag || {}; googletag.cmd = googletag.cmd || [];
        (function () {
	        var gads = document.createElement("script");
	        gads.async = true;
	        gads.type = "text/javascript";
	        var useSSL = "https:" == document.location.protocol;
	        gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
	        var node = document.getElementsByTagName("script")[0];
	        node.parentNode.insertBefore(gads, node);
        })();
        </script>
                <script type="text/javascript">
        googletag.cmd.push(function() {
            var pid_value = "addiction-and-trauma-and-recovery";
	    googletag.defineSlot('/21682974628/bangordailynews', [[300,250], [300,600]], "bdnads-blogs-top-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "top");
	    googletag.defineSlot('/21682974628/bangordailynews', [300,250], "bdnads-blogs-bottom-300x250")
			.addService(googletag.pubads())
			.setTargeting("pos", "bottom");
        googletag.defineSlot('/21682974628/bangordailynews', [[970,250], [970,90]], "bdnads-blogs-top-leaderboard")
            .addService(googletag.pubads())
            .setTargeting("pos", "top");

                            googletag.defineSlot('/21682974628/bangordailynews', [300,50], "bdnads-blogs-mobile-300x50")
	            .addService(googletag.pubads())
                .setTargeting("pos", "mobile");
	        googletag.defineSlot('/21682974628/bangordailynews', [[300,250]], "bdnads-inline-300x250")
		        .addService(googletag.pubads())
		        .setTargeting("pos", "inline");

        
							googletag.pubads().setTargeting( 'author', 'blog' );
			            googletag.pubads().setTargeting("pid", pid_value);
                        googletag.pubads().setTargeting("kw", ['Recovery Rocks', 'bangor', 'blog']);
            googletag.pubads().enableSingleRequest();           
            googletag.pubads().collapseEmptyDivs();
            googletag.enableServices();
	});
	</script>
    	<style type="text/css" id="bdnblog2013-header-css">
			.site-header {
			background: url(https://bdn-data.s3.amazonaws.com/blogs.dir/83/files/2013/10/cropped-Phoenix-Bird-Wallpaper.jpg) no-repeat scroll top;
			background-size: 1600px auto;
		}
			.site-title,
		.site-description {
			color: #edf7f8;
		}
		</style>
	
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Addiction, and Trauma, and Recovery" />
<meta property="og:url" content="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" />
<meta property="og:description" content="Today&#8217;s post is a guest blog fro one of the most courageous and badass women I&#8217;ve had the honor of knowing. She wishes to remain anonymous but her story is amazing. This year I celebrat…" />
<meta property="article:published_time" content="2020-12-23T12:56:36+00:00" />
<meta property="article:modified_time" content="2020-12-23T12:56:36+00:00" />
<meta property="og:site_name" content="Recovery Rocks" />
<meta property="og:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/83/files/2017/07/Recovery-Rocks.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="800" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="Addiction, and Trauma, and Recovery" />
<meta name="twitter:image" content="https://bdn-data.s3.amazonaws.com/blogs.dir/83/files/2017/07/Recovery-Rocks.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@bdnmaineblogs" />
<style type='text/css'>.site-title, .site-description {
text-shadow: 2px 2px #333;
}</style></head>

<body class="post-template-default single single-post postid-4926 single-format-standard sidebar no-avatars">


		<script type="text/javascript">
	(function() {
	  var ARTICLE_URL = window.location.href;
	  var CONTENT_ID = 'everything';
	  document.write(
	    '<scr'+'ipt '+
	    'src="//survey.g.doubleclick.net/survey?site=_co4sl7ki43vcs'+
	    '&amp;url='+encodeURIComponent(ARTICLE_URL)+
	    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+
	    '&amp;random='+(new Date).getTime()+
	    '" type="text/javascript">'+'\x3C/scr'+'ipt>');
	})();
	</script>
    
	 <div id="fb-root"></div>
	 <script>(function(d, s, id) {
			 var js, fjs = d.getElementsByTagName(s)[0];
			 if (d.getElementById(id)) return;
			 js = d.createElement(s); js.id = id;
			 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6&appId=748756371893770";
			 fjs.parentNode.insertBefore(js, fjs);
		 }(document, 'script', 'facebook-jssdk'));</script>
    
	<div id="page" class="hfeed site">
		<header id="masthead" class="site-header" role="banner">
            <div class="home-link">
				<a href="https://recoveryrocks.bdnblogs.com/" title="Recovery Rocks" rel="home">
					<h1 class="site-title">Recovery Rocks</h1>
                    <h2 class="site-description">Specializing In Assisting People In Recovery</h2>
				</a>
                <a class="bdn-link" href="http://bangordailynews.com/maine-blogs/?utm_source=Recovery+Rocks&utm_medium=footer">
	                <!--                    <img src="-->
	                <!--/images/BDN_Square.jpg" width="32" alt="BDN Maine" title="BDN Maine"/>-->
	                <!--                    Blog-->
	                <img src="https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/images/bdn_blogs_logo.jpg" alt="BDN Maine"
	                     title="BDN Maine"/>
                </a>
            </div>
			<div id="navbar" class="navbar">
				<nav id="site-navigation" class="navigation main-navigation" role="navigation">
					<h3 class="menu-toggle">Menu</h3>
					<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
					<div class="menu-default-container"><ul id="menu-default" class="nav-menu"><li id="menu-item-3016" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3016"><a href="http://recoveryrocks.bangordailynews.com/">Home</a></li>
<li id="menu-item-3015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3015"><a href="https://recoveryrocks.bdnblogs.com/category/recovery/">Recovery</a></li>
<li id="menu-item-3012" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3012"><a href="https://recoveryrocks.bdnblogs.com/category/addiction/">Addiction</a></li>
<li id="menu-item-3014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3014"><a href="https://recoveryrocks.bdnblogs.com/category/depression/">Depression</a></li>
<li id="menu-item-3013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3013"><a href="https://recoveryrocks.bdnblogs.com/category/archives/">Archives</a></li>
<li id="menu-item-3017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3017"><a href="https://recoveryrocks.bdnblogs.com/about/">About</a></li>
<li id="menu-item-3018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3018"><a href="https://recoveryrocks.bdnblogs.com/contact/">Contact</a></li>
<li id="menu-item-3633" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3633"><a href="https://recoveryrocks.bdnblogs.com/jims-recommended-links/">Jim&#8217;s Recommended Links</a></li>
</ul></div>					<form role="search" method="get" id="searchform" class="search-form" action="https://recoveryrocks.bdnblogs.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form>				</nav><!-- #site-navigation -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

                <div class="adSpot widget">
            <div id="bdnads-blogs-oop-interstitial">
                <script type="text/javascript">
                    googletag.cmd.push(function () {
                        googletag.display("bdnads-blogs-oop-interstitial");
                    });
                </script>
            </div>
        </div>
                            <div class="adSpot widget">
                                    <div id="bdnads-blogs-top-leaderboard">
                        <script type="text/javascript">
                            googletag.cmd.push(function () {
                                googletag.display("bdnads-blogs-top-leaderboard");
                            });
                        </script>
                    </div>
                            </div>
            <div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">

						
				<article id="post-4926" class="post-4926 post type-post status-publish format-standard has-post-thumbnail hentry category-addiction tag-addiction-recovery tag-ptsd tag-ptsd-trauma tag-recovery tag-substance-use-disorder tag-sud tag-traauma">
	<header class="entry-header">
		
            <h1 class="entry-title">Addiction, and Trauma, and Recovery</h1>

		
		<div class="entry-meta">
			<span class="date"><a href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" title="Permalink to Addiction, and Trauma, and Recovery" rel="bookmark"><time class="entry-date" datetime="2020-12-23T07:56:36+00:00">December 23, 2020</time></a></span><span class="categories-links"><a href="https://recoveryrocks.bdnblogs.com/category/addiction/" rel="category tag">Addiction</a></span><span class="tags-links"><a href="https://recoveryrocks.bdnblogs.com/tag/addiction-recovery/" rel="tag">addiction recovery</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/ptsd/" rel="tag">PTSD</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/ptsd-trauma/" rel="tag">PTSD trauma</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/recovery/" rel="tag">recovery</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/substance-use-disorder/" rel="tag">substance use disorder</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/sud/" rel="tag">SUD</a>, <a href="https://recoveryrocks.bdnblogs.com/tag/traauma/" rel="tag">traauma</a></span>					    <div class="author-byline">
			By <a href="https://recoveryrocks.bdnblogs.com/author/jlapierre/" title="Posts by Jim LaPierre" rel="author">Jim LaPierre</a>		    </div><!-- /.author-byline -->
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	
	<div class="entry-content entry">

        
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Addiction, and Trauma, and Recovery."
               data-url="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/"
               data-via='JimLaPierre'               data-related="JimLaPierre,bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/83/files/2017/07/Recovery-Rocks-250x250.png&description=Addiction, and Trauma, and Recovery" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


		<div class="p402_premium">
			<p>Today&#8217;s post is a guest blog fro one of the most courageous and badass women I&#8217;ve had the honor of knowing. She wishes to remain anonymous but her story is amazing.</p>
<div>
<p class="gmail-graf gmail-graf--p">This year I celebrated two years clean from mood and mind-altering substances with my 12 step fellowship. More accurately I reached two years clean on Sunday and I celebrated yesterday. It’s always a celebration of life in our fellowship- we celebrate your success and the program we are gifted. Those before us laid out the literature and steps so beautifully, that anyone can recover. Despite it being so “simple” and available to us all, most will not survive the disease of addiction.</p>
<p class="gmail-graf gmail-graf--p">So when you do, when you “recover”, we celebrate.</p>
<p class="gmail-graf gmail-graf--p">I use quotes around recover because the word alone implies a singular event. To say you are “recovered” is to say that you have finished the process. But recovery isn’t an event, it’s a lifelong process. I’ll never be recovered but I have a lifetime of recovery ahead of me. For an addict like myself viewing my work as done is a slippery slope to complacency and when people like me get complacent and we become stagnant, we put our recovery in danger.</p>
<p class="gmail-graf gmail-graf--p">I chose to work a 12-step program today because everything else I had tried had failed to keep me clean. I had moments, sometimes great lengths of time, where I could abstain from drugs (but never alcohol) and I use to call those moments recovery, until I looked at my consistent pattern of inability to stay clean no matter how many days I could white knuckle through cravings and withdrawals to prove to myself I could. There are thousands of pathways to recovery, so if you are reading this and a 12-step program doesn’t sound right for you, please keep looking for what works for you.</p>
<p class="gmail-graf gmail-graf--p">But this isn’t about the 12-steps. It isn’t about what fellowship or pathway to recovery worked for me to get here. Instead, I want to talk about what the second year of my recovery has looked like. I want to talk about it because when we talk about healing we tend to gussie it up in flowers and rainbows to attract those who aren’t here yet. I told my friends I planned to start advertising healing as the dark horse that it is, but they tell me that no one will come if they know.</p>
<p class="gmail-graf gmail-graf--p">And they are right.</p>
<p class="gmail-graf gmail-graf--p">The thing is, for some of us who are knee-deep in the muddy waters of healing from life, we need to hear that we aren’t alone. We need hope to keep us going. That is the gift I am afforded in my 12-step fellowship; entire groups of people who have been through and are going through the same things that we don’t talk about as often. I never have to be alone unless I choose to be alone.</p>
<p class="gmail-graf gmail-graf--p">And I’ve learned that I can’t save my life on my own.</p>
<p class="gmail-graf gmail-graf--p">In my first year of recovery, the focus was mainly on the substances. I didn’t touch a drug or alcohol, no matter what. One day at a time, sometimes one minute at a time, I clung to the hope and experience of everyone around me. Some people were celebrating 10, 20, 30 years clean during that first year, so neither hope nor experience was ever in short supply. They told me to do what they were doing and to believe that they believed, so I did.</p>
<p class="gmail-graf gmail-graf--p">I believed that they believed in me.</p>
<p class="gmail-graf gmail-graf--p">In my first year, I had a routine surgery and coded on the table. A few days later I woke up in ICU and celebrated my first 9 months clean from my hospital bed. To be fair, this is a far happier tale than I ever thought I would tell about the time I died. I had been an addict in active use trying to kill myself on a daily basis since I was 12 years old. To almost die, clean, from a routine surgery was a curveball I never saw coming. To wake up grateful to be alive was an experience I never believed would happen to me. That was the gift of my first year clean from drugs and alcohol.</p>
<p class="gmail-graf gmail-graf--p">I finally wanted to be alive.</p>
<p class="gmail-graf gmail-graf--p">Twenty years in and out of active addiction, I was already hostage to this disease at 12 years old. Why? How? I am a mom of four amazing young children- tweens. I look at them today and I can’t imagine them doing the things that I was doing at their age. When I woke up in ICU I would go on to say “For the first time in my entire life, I WANT to be alive. I am grateful to be alive.” And while that was, and still is, true for me- it was also heartbreaking. How can you be so young and chase death with such conviction? What was I missing other than all of my memories before the age of 12; or is that exactly what I was missing?</p>
<p class="gmail-graf gmail-graf--p">The information.</p>
<p class="gmail-graf gmail-graf--p">I celebrated my first year clean three months later and before I got there, the darkness started to set in. That heartbreak nagged me long after I left the hospital bed. It was a constant twang in the back of my mind that kept coloring everything I was trying to do. “How did I get here?” “What happened to me?” “Where did it all go wrong?” Awareness would ebb and flow, with glimpses of the memories I had lost, and unearthing of feelings I had never experienced before. Sadness. Grief. Despair.</p>
<p class="gmail-graf gmail-graf--p">You might think to be suicidal at 12 years old, one would have to experience those feelings before now. But I couldn’t remember experiencing them and once I started medicating them, they never existed again. I know what pain feels like; I know what anger and bitterness taste like. But I never remembered feeling the depths of despair that I felt at my first-year celebration when the first bit of awareness finally came.</p>
<p class="gmail-graf gmail-graf--p">I am a multiple child sexual abuse survivor.</p>
<p class="gmail-graf gmail-graf--p">Complex Post Traumatic Stress Disorder (C-PTSD) is a result of prolonged and sustained exposure to interpersonal trauma from which there is no escape. I came into my recovery already having this diagnosis as a survivor of domestic violence and multiple sexual assaults as a teenager. I had begun unpacking that trauma in my first year because it was easy for me; I was already talking about it anyway. I can tell it to you now without being triggered by its realness:</p>
<p class="gmail-graf gmail-graf--p">As a teenager I was molested by my mother&#8217;s partner for many years; when their relationship ended I was 14 years old and, not having a singular idea what or why I was doing it, I sought out companionship of adult men who would sexually assault me. To be very clear, children are not the ones with the onus of responsibility to not have sex with adults. There were many men willing to groom a child and I was victimized multiple times. I packed all of that trauma up into pretty packages, set them on ornate shelves in my mind, and moved on with my life. Soon after turning 19 I met my now ex-husband. We were together for 12 years, married for 8, and our marriage was wrought with multiple (physical, emotional, sexual, financial, and spiritual) forms of abuse. We were both addicts in and out of active use together which was a recipe for disaster. Because I chose to not do the work and just keep it moving, I jumped from one awful relationship to the next and I almost lost my life.</p>
<p class="gmail-graf gmail-graf--p">And my children.</p>
<p class="gmail-graf gmail-graf--p">Knowing all of this motivated me into recovery in the first place: I didn’t want to use anymore, I didn’t want to find myself in another abusive relationship, and I had made a commitment long ago to be to my children what I had always needed- which I had been trying to be all along. In my first year clean I dove headfirst into trauma therapy because I believed in the necessity of addressing your mental health in order to recover. Unaddressed mental illness and trauma keep us hostage to a disease that wants us dead. I wrote my last blog about my children and healing for them. Now I am writing about myself and healing for me.</p>
<p class="gmail-graf gmail-graf--p">When the awareness came at my first-year mark, it came in the way of intrusive thoughts and flashbacks, night terrors and sleep paralysis and a constant flood of the fight or flight response. I spent hours in a ball, either in the bottom of my shower or the corner of my couch, crying and trying to convince myself that I was either crazy or making it all up- knowing that I couldn’t make it up if I tried. All the while this is happening, I was just trying to stay clean, literally and figuratively. I was just trying to stay present for my kids to make it through the holidays.</p>
<p class="gmail-graf gmail-graf--p">My sister is a sexual predator and I was her victim.</p>
<p class="gmail-graf gmail-graf--p">I had a professional photoshoot for work the day the memories came back; barely 10 years old at any given second, I was alone in the car, behind the wheel, when I remembered. I was sweating through my blazer, holding back vomit, crying on the forty-minute ride to the salon. When I looked at the pictures afterwards all I could see was the pain and fear in my own eyes- I promised myself in that moment that I would do the work, no matter how painful, to save myself from ever having to feel the way I felt that day, even one more time.</p>
<p class="gmail-graf gmail-graf--p">I had no idea what darkness I was wading into.</p>
<p class="gmail-graf gmail-graf--p">Growing up Pentecostal was an awful experience for me. In fact, it was so traumatic that it drove me from any kind of belief. At 9 years old I stopped believing in everything. It was safer that way. When I came into recovery, when I joined a 12-step fellowship, I identified as an atheist. By the end of my first year, I had shifted to a spiritual atheist. I could get with there being a greater purpose and something much bigger than me, but you couldn’t ask me to believe in a God. The God I knew caused pain and suffering and I refused to believe that a “God” would ever be so malicious and perverse- I decided at 9 that there was just no such thing.</p>
<p class="gmail-graf gmail-graf--p">No Easter Bunny. No Tooth-Fairy. No Santa. No Good. No God.</p>
<p class="gmail-graf gmail-graf--p">Someone told me at the beginning of the year that the spiritual journey I was on wouldn’t go any further if I didn’t address my resentment against God; after all, I didn’t believe in him so what was I so angry about anyway? More specifically- who was I so angry at? It was time to dig into that question in order to free myself from the resentment that stood between me and where I was trying to go. In our fellowship, we have steps that are written in such a way that you resolve your resentments along the way. Sometimes you have to resolve the resentment to work through the steps. That was me. I was being asked to believe in anything greater than myself- The Universe. Humanity. Community. Tribe. All greater than me and all evidenced to restore me to sanity when I became an active participant in my own life.</p>
<p class="gmail-graf gmail-graf--p">But then I was asked to turn my life over to the care of a Higher Power.</p>
<p class="gmail-graf gmail-graf--p">I promised myself early on that nothing would be off the table. Everything was up for digging into and unpacking. How free do you want to be? As free as I can get. So I went on an evangelical women’s retreat with some of my tribe who believe in a God that I was certain didn’t exist. I was determined to keep an open mind to hear what I needed to hear. By that point I had started to heavily converse with my ceiling and the sky at night, leaning into the strength of the Universe I promised myself I would grow from the retreat that weekend.</p>
<p class="gmail-graf gmail-graf--p">Mother wounds and Father wounds.</p>
<p class="gmail-graf gmail-graf--p">I didn’t hear God that weekend. I certainly didn’t leave feeling closer to believing in him either. In fact, some of what I heard was so close to what I had learned in the Pentecostal church and reaffirmed my conviction that their God wasn’t a “God” I could ever believe in. That was exactly what I needed- to learn what I didn’t believe in in order to make room for what I do believe. Bigger than that, I heard a message that I had wounds from my childhood that needed addressing. The trouble was, I couldn’t remember what those wounds were. My parents were divorced, but by this point I’m divorced as well and I can empathize with how that happens. I don’t hold their divorce against them.</p>
<p class="gmail-graf gmail-graf--p">But I can’t remember what my body is holding against them on my behalf.</p>
<p class="gmail-graf gmail-graf--p">After the retreat I needed answers. I continued to ask the Universe to help me remember but I also knew I needed a reliable source that wasn’t my own mind. I had no one else I could ask except my father. We had been estranged since coming into recovery because we had a public falling out about some version of events that I had in my memory bank, not aware at the time that that bank account was never in my name. When the pandemic hit we had just met in person for the first time and when it was over I was ready to slam the door shut again. Once the door was opened my father surprised me by putting his foot in the crack to prevent me from shutting him out.</p>
<p class="gmail-graf gmail-graf--p">He knew when he left that he left me behind.</p>
<p class="gmail-graf gmail-graf--p">I didn’t know what to do with that. I had mounting evidence that I had been left behind in some special hell that had scarred me so deeply that my own body was a war zone, inside and out. I scrubbed in scalding hot water to feel clean. I could feel breath on my neck when I was alone. In the dark of my room when my partner’s face disappeared, I recoiled in terror from someone who wasn’t there. Locked on the couch I was floating above my body and my children for hours a day, until I couldn’t any longer. When I began to return fire and wage war on myself, still clean, I knew something was very very wrong.</p>
<p class="gmail-graf gmail-graf--p">Eighteen months clean was its own special kind of hell.</p>
<p class="gmail-graf gmail-graf--p">When things get hard I like to try even harder to help someone else. I like to have people projects and it works best if none of them are named “Me.” In this case, it wasn’t such a bad thing as I made projects out of my own children. While others were worried about academics I was worried about mental health. I remembered my other resentments that I had forgotten: the DSM and the people who weaponized it against me as a child, instead of saving me. But in order to help my children, I had to address my resentment quickly which forced me to confront my own mental health that I had neglected in a bid to avoid the very thing I hated- assessment and treatment. For all of us.</p>
<p class="gmail-graf gmail-graf--p">We have survived together for 8 months in a pandemic. We are resilient and strong.</p>
<p class="gmail-graf gmail-graf--p">The relationship that grew between my father and I during those beginning months of the Pandemic was nothing short of its own gift. No adult had ever shown me accountability. No adult had ever said, “I’m sorry I hurt you.” My parents didn’t right their wrongs, they dug in deeper. At least the parents I had thought I knew. Who knew I had always had a Dad who loved me? Not me. I know what you’re thinking “But he left you behind!” I thought so, too. I thought that for so long that I believed it, until he became a reliable source in my life and helped me remember what I had almost killed myself trying to forget.</p>
<p class="gmail-graf gmail-graf--p">We were raised to hurt each other and we can never get our relationship back.</p>
<p class="gmail-graf gmail-graf--p">My relationships changed so drastically that they don’t look at all like they did when I came in. Lifetime friendships developed term limits and their time came up. The more people were removed from my life the darker it became. I felt like I was waging war on my trauma with a one-man army. Even in my fellowship, I found myself feeling lonely and isolated in my pain. No one talks about these things. Few people call their monsters by name. I was watching my children get better; day by day my projects ran out of names. By the time I completed my own summer accelerated college program, in the middle of the pandemic with now four children at home, I was drowning again- but this time not silently.</p>
<p class="gmail-graf gmail-graf--p">Never alone ever again, unless I choose to be.</p>
<p class="gmail-graf gmail-graf--p">While not everyone was doing recovery the same way as me, what my community and tribe had to offer was solidarity, comradery, “Me too’s,” empathy, and compassion. Many of us get here the same way; trauma is THE gateway drug, so whether we call them by name or not, we all suffer similar demons. Some of us thought we were entirely, permanently, and uniquely fucked up to the point that there was no hope for us. But we found each other and so we found hope again. I wasn’t quite sure I was going to make it to my two-year celebration and to be frank, it wasn’t the drugs. I was feeling hopeless.</p>
<p class="gmail-graf gmail-graf--p">I wasn’t sure I could possibly survive the war.</p>
<p class="gmail-graf gmail-graf--p">When I finished my classes I had little breathing room before the intrusive thoughts, flashbacks, hypervigilance, and soul rot returned- it never really went away to begin with. It was just one band-aid to the next. My classes triggered a new tidal-wave of awareness that came with a force that took my breath away and sunk me into a depression that felt suffocating. I felt like I had two choices: do what I always did, and allow myself to suffer unnecessarily, or put bumpers on my recovery and seek medication management for symptoms that had become debilitating.</p>
<p class="gmail-graf gmail-graf--p">But what about that resentment and fear?</p>
<p class="gmail-graf gmail-graf--p">I was misdiagnosed with Bipolar and Borderline Personality disorder as a teenager. As a result, I was mistreated by providers, family, friends, and partners. Those diagnoses were wielded against me for over a decade and became my identity after a time. No one knew how traumatized I was- not even me. That promise I made to myself to do for my kids what was not done for me, meant I had to be honest when I sought help for them. I was accountable and transparent about their trauma. I am their advocate and their ally. When it was time to do the same for myself and seek treatment I felt a sense that I was re-victimizing myself all over again, and that was enough to make my skin crawl and my insides want to come out.</p>
<p class="gmail-graf gmail-graf--p">I’m learning how to be to myself who I am to my children.</p>
<p class="gmail-graf gmail-graf--p">C-PTSD, ADHD, and Bipolar Disorder (just to name a few) all have overlapping symptoms and C-PTSD is frequently misdiagnosed as the latter. When I was misdiagnosed as a teenager I picked up the DSM-4 and taught myself a thing, two, or twenty about mental health. I made a career for myself as a mental health professional who specializes in complex trauma, childhood sexual abuse, and substance abuse. So when it came time to advocate for myself I knew what to do. Even I surprise myself with how far I have come despite the weight of what felt like the world bearing down on me.</p>
<p class="gmail-graf gmail-graf--p">Our story isn’t so different from other children of borderline mothers.</p>
<p class="gmail-graf gmail-graf--p">As I write this, I am still knee-deep in the shit, and continuing to take baby steps through it. I feel like I am being yanked through the grief cycle every day as I peel back layer after layer to my memories and remember all of the things that my body has never forgotten. I’m never surprised anymore when something gross and heartbreaking breaks through and I’m confronted with the realities of mine and my sister&#8217;s life. Today I have forgiven her for more than I ever knew I needed to, because I can see her for the broken child that she is. My sister is 7 years older than me, who knows what her body remembers even if her mind has forgotten? We were just babies and she was never given a chance.</p>
<p class="gmail-graf gmail-graf--p">I am alive to celebrate and write this, today. I made it.</p>
<p class="gmail-graf gmail-graf--p">When people ask me what I am addicted to I tell them death; when they ask what I’m recovering from I say life. I have had to recover from the depths of hell and fight tooth and nail on the slim chance that was provided for me from the start. It’s my responsibility to do for me what was never done and to heal from the pain that holds me hostage. There isn’t a single area of my life that is off the table today, because I never want to be here again.</p>
<p class="gmail-graf gmail-graf--p">I never want to chase death again, not even one more time.</p>
</div>

		</div>
			
			        <script type="text/javascript">
            try {
                _402_Show();
            } catch (e) {
            }
        </script>
	    
			
    
    <!-- AddThis Button BEGIN -->
    <div class="addthis_toolbox addthis_default_style">
        
        <!-- Facebook button -->
        <div class='share-button'>
            <div class="fb-like" data-href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
        </div>

        <!-- Tweet button -->
        <div class='share-button'>
            <a href="https://twitter.com/share" 
               class="twitter-share-button" 
               data-text="Addiction, and Trauma, and Recovery."
               data-url="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/"
               data-via='JimLaPierre'               data-related="JimLaPierre,bdnmaineblogs,bangordailynews"
               data-lang="en">Tweet</a>
            <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
        </div>


        <!-- Pin it button -->
        <div class='share-button'>
        <a href="//www.pinterest.com/pin/create/button/?url=https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/&media=https://bdn-data.s3.amazonaws.com/blogs.dir/83/files/2017/07/Recovery-Rocks-250x250.png&description=Addiction, and Trauma, and Recovery" data-pin-do="buttonPin" data-pin-config="none">
            <img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" />
        </a>
        </div>
        
        <div class='share-button'>
            <a class="addthis_counter addthis_pill_style"></a>
        </div>
    </div>
    <!-- AddThis Button END -->


	</div><!-- .entry-content -->

	
	<footer class="entry-meta">
	    				                    
<div class="author-info">
	<div class="author-avatar">
			    <img src="http://gravatar.com/avatar/5aab23fae6c551849c60363f5940356b?s=74&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F83%2Ffiles%2F2012%2F03%2Frecoveryrocksheadshot.jpg"
		 alt="Jim LaPierre"
		 title="Jim LaPierre"
		 class="gravatar avatar"
		 align="left"
		 width="74" 
		 height="74" 
		 />
	</div><!-- .author-avatar -->
	<div class="author-description">
		<h2 class="author-title">About Jim LaPierre</h2>
		<p class="author-bio">
			Jim LaPierre LCSW CCS is the Executive Director of Higher Ground Services in Brewer, Maine. He is a Recovery Ally, mental health therapist and addictions counselor. He specializes in facilitating recovery (whether from addiction, trauma, depression, anxiety, or past abuse) overcome obstacles, and improve their quality of life. Jim is the cofounder of Sobernow.com an online addiction recovery program that is affordable and provides complete anonymity                    
                                                    <a class="author-link" href="https://recoveryrocks.bdnblogs.com/author/jlapierre/" rel="author">
                                    View all posts by Jim LaPierre <span class="meta-nav">&rarr;</span>                            </a>
                        		</p>
	</div><!-- .author-description -->
</div><!-- .author-info -->		    			</footer><!-- .entry-meta -->
</article><!-- #post -->
					<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">

			<a href="https://recoveryrocks.bdnblogs.com/2020/12/07/addiction/coping-with-powerlessness/" rel="prev"><span class="meta-nav">&larr;</span> Coping with powerlessness</a>			<a href="https://recoveryrocks.bdnblogs.com/2021/01/07/addiction/hypervigilance-and-addiction-recovery/" rel="next">Hypervigilance and addiction recovery <span class="meta-nav">&rarr;</span></a>
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	   
		    
				<div class="OUTBRAIN entry-meta" data-src="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" data-widget-id="AR_1" data-ob-template="bangordaily" ></div>
				<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script>

				
<div id="comments" class="comments-area comment-respond">
    <div class="comment-list">
            
            <div class="fb-comments" data-href="http://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/" data-colorscheme="light" data-width="604"></div>
            
                        <script>
                jQuery(document).ready(function( $ ) {
                     FB.Event.subscribe('comment.create', function(response) {

                        //Send an email with ajax

                        $.ajax({
                            type: "GET",
                            url: "/wp-admin/admin-ajax.php?action=bdn_facebook_comment_notifications_send",
                            data: { 
                                post_author : "counseling@roadrunner.com", 
                                post_title : "Addiction, and Trauma, and Recovery", 
                                post_link : "https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/", 
                                post_id : "4926"
                            }, 
                            dataType: "json",
                            beforeSend:  function() {
                                console.log('Sending message');
                            },
                            success: function(html){
                               console.log('Success sending email');
                               console.log(html);
                            },
                            error: function(html){
                                console.log('There was an error sending the notification email');
                                console.log(html)
                            }
                        });
                     });
                });
               
            </script>
                        
            
            
           
    </div>
</div><!-- #comments -->

			
		</div><!-- #content -->
	</div><!-- #primary -->


	
    <div id="tertiary" class="sidebar-container" role="complementary">
	<div class="sidebar-inner">
	    <div class="widget-area">

		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-top-300x250">
		     <script type="text/javascript">
			  googletag.cmd.push(function() {
				googletag.display("bdnads-blogs-top-300x250");
			   });
		      </script>
		    </div>
		</div>

		<aside id="bdn_blog_bio-2" class="widget widget_bdn_blog_bio"><h3 class="widget-title">                <div class="widget blog-authors">
                    <h3>Jim LaPierre</h3>
                    <a class="author-avatar" href="http://www.hgscounseling.com">
                        <img src="http://gravatar.com/avatar/5aab23fae6c551849c60363f5940356b?s=80&d=https%3A%2F%2Fbdn-data.s3.amazonaws.com%2Fblogs.dir%2F83%2Ffiles%2F2012%2F03%2Frecoveryrocksheadshot.jpg"
                             alt="Jim LaPierre"
                             title="Jim LaPierre"
                             class="gravatar avatar"
                             align="left"
                             width="80" 
                             height="80" 
                         />
                    </a>
                    <p>
                        Jim LaPierre LCSW CCS is the Executive Director of Higher Ground Services in Brewer, Maine. He is a Recovery Ally, mental health therapist and addictions counselor. He specializes in facilitating recovery (whether from addiction, trauma, depression, anxiety, or past abuse) overcome obstacles, and improve their quality of life. Jim is the cofounder of Sobernow.com an online addiction recovery program that is affordable and provides complete anonymity                    </p>
                    
                                            <a href="https://twitter.com/JimLaPierre" class="twitter-follow-button" data-show-count="true">
                            Follow @JimLaPierre                        </a>
                        <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
                                        
                                            <div class="fb-like-box" 
                             data-href="https://www.facebook.com/healingandovercoming"
                             data-width="300" 
                             data-show-faces="false" 
                             data-header="false" 
                             data-stream="false" 
                             data-show-border="false">
                        </div>
                    
                                        
                    
                </div>
                
        </h3></aside>        <div class="bdn-blogs-widget widget category-bangor">
            <!--
            Document   : Formerly bdn-blog-promotions.css
            Created on : Sep 16, 2013, 4:43:03 PM
            Author     : Pattie Reaves
            Version	   : 1.1
            Description: Styles the BDN blogs widget.
             -->
            <style>
                .bdn-blog-headshot {
                    width: 70px;
                    height: 70px;
                    -moz-border-radius: 35px;
                    -webkit-border-radius: 35px;
                    border-radius: 35px;
                }

                .bdn-blogs-widget-posts img {
                    margin: 0 10px 10px 0;
                }

                .bdn-blogs-widget-posts {
                    border: #006743 solid 1px;
                    padding: 5px;
                }

                .bdn-blogs-widget-header {
                    overflow: auto;
                    background-color: #006743;
                    color: #fff;
                }

                .bdn-blogs-widget-header img {margin-right: 10px;}
                .bdn-blogs-widget-header h3 {font-size: 50px; clear: right; margin: 10px;}
                .widget .bdn-blogs-widget-header a, .widget .bdn-blogs-widget-header a:visited {color: #fff; line-height: 30px;}

                .blogwidget {
                    margin: 10px 0;
                    padding: 10px 0;
                    overflow: auto;
                    border-bottom: 1px solid #ddd;
                }

                .blogwidget:first-of-type {
                    margin-top: 0;
                }
                .blogwidget:last-of-type {
                    margin-bottom: 0;
                }

                .bdn-blogs-widget-header .promo-links {margin-left: 5px;}

                h4.blogstory, h5.blogname {
                    margin: 0;
                }

                h5.blogname {text-transform: uppercase; font-size: 75%;}

                a.post-image {
                    text-indent: -99999px;
                    display: block;
                    width: 100%;
                    height: 180px;
                    margin-bottom: 5px;
                    background-repeat: no-repeat;
                    background-position: center center;
                    background-color: #ccc;
                }
            </style>
            <div class="bdn-blogs-widget-header">
                <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget">
                    <img src="//bangordailynews.com/wp-content/themes/bdn/images/bdnmaine_110.png" width="60"
                         align="left">
                </a>
                <h3>
                    <a href="http://bangordailynews.com/maine-blogs/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget">
                        Blogs
                    </a>
                </h3>
                <div class="promo-links">
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/be-a-bdn-blogger/">Be a BDN
                        blogger</a> |
                    <a class="promo-link" href="http://bangordailynews.com/maine-blogs/">Browse BDN blogs</a>
                </div>
            </div>
            <div class="bdn-blogs-widget-posts">
				<!-- Blogs widget served from memcached --><!-- blogs category: bangor -->
            <div id="blogwidget_1" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://recoveryrocks.bdnblogs.com/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                       target=_blank title="Specializing In Assisting People In Recovery">
						Recovery Rocks                    </a>
                </h5>

				                    <!-- Image from post image -->
                    <a
                            class="post-image"
                            style="background: #ccc url('https://i1.wp.com/bdn-data.s3.amazonaws.com/blogs.dir/83/files/2013/10/recoveryrocksheadshot.jpg?fit=94%2C99&ssl=1'); background-position: center center; background-size: cover;"
                            href="https://recoveryrocks.bdnblogs.com/2021/01/07/addiction/hypervigilance-and-addiction-recovery/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                            title="Hypervigilance and addiction recovery">
						Hypervigilance and addiction recovery                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://recoveryrocks.bdnblogs.com/2021/01/07/addiction/hypervigilance-and-addiction-recovery/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                       target=_blank>
						Hypervigilance and addiction recovery                    </a>
                </h4>
            </div>

		
            <div id="blogwidget_2" class="blogwidget">

                <h5 class="blogname">
                    <a href="https://westofthefields.bdnblogs.com/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                       target=_blank title="Weekly alternative music podcast straight from Orono, Maine">
						West of The Fields                    </a>
                </h5>

				                    <!-- Image from image
                    Syndicate https://bdn-data.s3.amazonaws.com/blogs.dir/222/files/2014/02/c8d82ae6981b11e3a43a0acef2407122_8-300x300.jpg                    Image https://bdn-data.s3.amazonaws.com/blogs.dir/222/files/2014/02/c8d82ae6981b11e3a43a0acef2407122_8-300x300.jpg                    Blog Image                     -->
                    <a
                            class="post-image"
                            style="background-image:url('https://bdn-data.s3.amazonaws.com/blogs.dir/222/files/2014/02/c8d82ae6981b11e3a43a0acef2407122_8-300x300.jpg'); background-position: center center; background-size: contain; background-color: rgb(90, 129, 170);"
                            href="https://westofthefields.bdnblogs.com/2020/12/31/shows/new-music-including-pale-waves-rina-sawayama-billie-eilish-and-grimes-on-this-weeks-west-of-the-fields-podcast/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                            title="New music including Pale Waves, Rina Sawayama, Billie Eilish and Grimes on this week's West Of The Fields podcast">

						West of The Fields                    </a>

				
                <h4 class="blogstory">
                    <a class="blogstory"
                       href="https://westofthefields.bdnblogs.com/2020/12/31/shows/new-music-including-pale-waves-rina-sawayama-billie-eilish-and-grimes-on-this-weeks-west-of-the-fields-podcast/?utm_campaign=Recovery+Rocks&utm_source=bangor-widget"
                       target=_blank>
						New music including Pale Waves, Rina Sawayama, Billie Eilish and Grimes on this week's West Of The Fields podcast                    </a>
                </h4>
            </div>

		            </div>

        </div><!-- /.bdn-blogs-widget -->

		<!-- Blogs widget took 0.002883 seconds to load. -->
		<div class="adSpot widget" style="min-height:270px;">
		    <div id="bdnads-blogs-bottom-300x250">
			 <script type="text/javascript">
			      googletag.cmd.push(function() {
				    googletag.display("bdnads-blogs-bottom-300x250");
			       });
			  </script>
		    </div>
		</div>
	    </div><!-- .widget-area -->

	</div><!-- .sidebar-inner -->
    </div><!-- #tertiary -->
	
	

		</div><!-- #main -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div id="secondary" class="sidebar-container" role="complementary">
		<div class="widget-area">
			<aside id="search-2" class="widget widget_search"><form role="search" method="get" id="searchform" class="search-form" action="https://recoveryrocks.bdnblogs.com">
	<label>
		<span class="screen-reader-text" for="s">Search for:</span>
		<input type="search" class="search-field" value="" name="s" placeholder="Search ..." title="Search for:">
	</label>
	<input type="submit" class="search-submit" id="searchsubmit" value="Search">
</form></aside>                <div class="widget">
                    <h3 class="widget-title">
                        Subscribe by Email
                    </h3>
                    <form action="http://feedburner.google.com/fb/a/mailverify" 
                          method="post" 
                          class="feedburner-form"
                          target="popupwindow" 
                          onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=feedburner_slug', 'popupwindow', 'scrollbars=yes,width=550,height=520');return true"
                      >
                            <p>
                                Get Updates from Recovery Rocks                            </p>
                            <input type="text" name="email" placeholder="you@email.com" width="100%"/>
                            <input type="hidden" value="feedburner_slug" name="uri"/>
                            <input type="hidden" name="loc" value="en_US"/>
                            <input type="submit" value="Subscribe" />
                    </form>
                </div>
            <aside id="rss_links-2" class="widget widget_rss_links"><h3 class="widget-title">Subscribe</h3><p><a target="_self" href="https://recoveryrocks.bdnblogs.com/feed/" title="Subscribe to Posts"><img src="https://recoveryrocks.bdnblogs.com/wp-content/plugins/jetpack/images/rss/orange-small.png" alt="RSS Feed" /></a>&nbsp;<a target="_self" href="https://recoveryrocks.bdnblogs.com/feed/" title="Subscribe to Posts">RSS - Posts</a></p>
</aside>		<aside id="recent-posts-2" class="widget widget_recent_entries">		<h3 class="widget-title">Recent Posts</h3>		<ul>
											<li>
					<a href="https://recoveryrocks.bdnblogs.com/2021/01/07/addiction/hypervigilance-and-addiction-recovery/">Hypervigilance and addiction recovery</a>
									</li>
											<li>
					<a href="https://recoveryrocks.bdnblogs.com/2020/12/23/addiction/addiction-and-trauma-and-recovery/">Addiction, and Trauma, and Recovery</a>
									</li>
											<li>
					<a href="https://recoveryrocks.bdnblogs.com/2020/12/07/addiction/coping-with-powerlessness/">Coping with powerlessness</a>
									</li>
											<li>
					<a href="https://recoveryrocks.bdnblogs.com/2020/11/16/addiction/the-cost-of-carrying-resenments/">The cost of carrying resenments</a>
									</li>
											<li>
					<a href="https://recoveryrocks.bdnblogs.com/2020/11/04/addiction/growing-up-in-an-alcoholic-family/">Growing up in an alcoholic family</a>
									</li>
					</ul>
		</aside>		</div><!-- .widget-area -->
	</div><!-- #secondary -->

			<div class="site-info">
                            <a href="http://bangordailynews.com/maine-blogs/?utm_source=Recovery+Rocks&utm_medium=footer">
                                <img src="https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/images/BDN_Square.jpg" width="32" />
                                Recovery Rocks is a member of the BDN Maine Blog network.
                            </a>
			</div><!-- .site-info -->
			
			<!--Desktop only-->
			<div id="footer">
			    <div id="box-wrap">
				<div id="box1">
				    <h1 class="headline">Bangor Daily News</h1>
				    <ul class="sitemap">
					<li><a href="http://archive.bangordailynews.com/">Archives</a></li>
					<li><a href="http://bangordailynews.com/">News</a></li>
					<li><a href="http://bangordailynews.com/business/">Business</a></li>
					<li><a href="http://bangordailynews.com/sports/">Sports</a></li>
					<li><a href="http://bangordailynews.com/outdoors/">Outdoors</a></li>
					<li><a href="http://bangordailynews.com/homestead/">Homestead</a></li>
					<li><a href="http://bangordailynews.com/link/tv-listings/">TV Listings</a></li>
					<li><a href="http://obituaries.bangordailynews.com/">Obituaries</a></li>
					<li><a href="http://bangordailynews.com/events/">Things to Do</a></li>
					<li><a href="http://bangordailynews.com/special-sections/">Custom Publications</a></li>
					<li><a href="http://marketplace.bangordailynews.com/?post_type=coupon">Coupons</a></li>
					<li><a href="http://bangordailynews.com/weather/">Weather</a></li>
					<li><a href="http://bangordailynews.com/closings/">Storm Cancellations</a></li>
				    </ul>
				</div><!-- #box1 -->
				<div id="box2">
				    <h1 class="headline">About Us</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/about/">BDN History</a></li>
					<li><a href="http://external.bangordailynews.com/bdn-anniversary/">BDN 120 Years</a></li>
					<li><a href="http://bangordailynews.com/contact">Contact Us</a></li>
					<li><a href="http://store.bangordailynews.com/">Purchase Photos</a></li>
					<li><a href="http://nie.bangordailynews.com/">Newspapers in Education</a></li>
					<li><a href="http://bangordailynews.com/terms-of-service/">Terms of Service</a></li>
					<li><a href="http://bangordailynews.com/privacy/">Privacy Policy</a></li>
				    </ul>
				    <h1 class="headline" style="margin-top: 15px;">Subscribe</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/subscribe/">Bangor Daily News Subscriptions</a></li>
					<li><a href="http://bangordailynews.com/staff/circulation/">Manage Your Subscription</a></li>
					<li><a href="http://bangordailynews.com/newsletters/">Email Updates</a></li>
					<li><a href="http://bangordailynews.com/feed/">RSS</a></li>
				    </ul>
				</div><!-- #box2 -->
				<div id="box3">
				    <h1 class="headline">Sales and Marketing</h1>
				    <ul class="sitemap">
					<li><a href="http://bangordailynews.com/staff/advertising/classifieds/">Classifieds</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Print and Online Advertising</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/special-sections/">Custom Publications and The Weekly</a></li>
					<li><a href="http://bangordailynews.com/staff/advertising/">Advertising Staff Directory</a></li>
					<li><a href="http://creativeservices.bangordailynews.com/guide-to-sending-files/">Creative Services-Guide to Sending Files</a></li>
				    </ul>
				</div><!-- #box3 -->
				<div id="box4">
				    <h1 class="headline">On Facebook</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.facebook.com/bangordailynews" title="The Bangor Daily News on Facebook">The Bangor Daily News</a></li>
                        <li><a href="http://www.facebook.com/bdnmainemidcoast" title="BDN Midcoast on Facebook">Midcoast</a></li>
                        <li><a href="http://www.facebook.com/bdnmaineportland" title="BDN Portland on Facebook">Portland</a></li>
                        <li><a href="http://www.facebook.com/bdnmainearoostook" title="BDN Aroostook on Facebook">Aroostook</a></li>
                        <li><a href="http://www.facebook.com/bdnmainedowneast" title="BDN Midcoast on Facebook">Downeast</a></li>
                        <li><a href="http://www.facebook.com/bdnmainehancock" title="BDN Hancock on Facebook">Hancock</a></li>
                        <li><a href="http://www.facebook.com/pages/BDN-Katahdin-and-Lincoln-Lakes-Region-News/139993822727247" title="BDN Katahdin and Lincoln Lakes Region on Facebook">Katahdin and Lincoln Lakes Region</a></li>
                        <hr />
                        <li><a href="http://www.facebook.com/BDNFoodForThought" title="BDN Food on Facebook">Food</a></li>
                        <li><a href="https://www.facebook.com/bdnmaineoutdoors" title="BDN Outdoors on Facebook">Outdoors</a></li>
                        <li><a href="https://www.facebook.com/BDNMaineFamilies" title="BDN Maine Families on Facebook">Maine Families</a></li>
                        <li><a href="https://www.facebook.com/BDNBlogs" title="BDN Blogs on Facebook">BDN Blogs</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/pages/BDN-Editorial-Opinion/107406425993156" title="BDN Editorial and Opinion on Facebook">Editorial and Opinion</a></li>
                        <hr />
                        <li><a href="https://www.facebook.com/bdnmainesports" title="BDN Maine Sports on Facebook">Maine Sports</a></li>
                        <li><a href="https://www.facebook.com/bdnhssports" title="BDN High School Sports on Facebook">High School Sports</a></li>
                    </ul>
                    <h1 class="headline">On Twitter</h1>
                    <ul class="sitemap">
                        <li><a href="http://www.twitter.com/bangordailynews" title="The Bangor Daily News on Twitter">@bangordailynews</a></li>
                        <li><a href="http://www.twitter.com/bdnpolitics" title="The Bangor Daily News on Twitter">@bdnpolitics</a></li>
                        <li><a href="http://www.twitter.com/bdnmaineblogs" title="The Bangor Daily News Blogs on Twitter">@bdnmaineblogs</a></li>
                        <li><a href="http://www.twitter.com/bdnmainefocus" title="The Bangor Daily News Maine Focus on Twitter">@bdnmainefocus</a></li>
                    </ul>
				</div><!-- #box4 -->
			    </div><!--#box-wrap -->
			</div>
			
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3QLSF"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
	<div style="display:none">
	</div>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202101'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var emailL10n = {"ajax_url":"https:\/\/recoveryrocks.bdnblogs.com\/wp-admin\/admin-ajax.php","max_allowed":"5","text_error":"The Following Error Occurs:","text_name_invalid":"- Your Name is empty\/invalid","text_email_invalid":"- Your Email is empty\/invalid","text_remarks_invalid":"- Your Remarks is invalid","text_friend_names_empty":"- Friend Name(s) is empty","text_friend_name_invalid":"- Friend Name is empty\/invalid: ","text_max_friend_names_allowed":"- Maximum 5 Friend Names allowed","text_friend_emails_empty":"- Friend Email(s) is empty","text_friend_email_invalid":"- Friend Email is invalid: ","text_max_friend_emails_allowed":"- Maximum 5 Friend Emails allowed","text_friends_tally":"- Friend Name(s) count does not tally with Friend Email(s) count","text_image_verify_empty":"- Image Verification is empty"};
/* ]]> */
</script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-content/plugins/wp-email/email-js.js?ver=2.67.5'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/js/functions.js?ver=2013-07-18'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-content/themes/bdnblog2013/js/out-of-page-ad.js?ver=2018-07-18'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-content/mu-plugins/js/submitevent.js?ver=2'></script>
<script type='text/javascript' src='https://recoveryrocks.bdnblogs.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202101.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.9',blog:'33559295',post:'4926',tz:'-5',srv:'recoveryrocks.bdnblogs.com'} ]);
	_stq.push([ 'clickTrackerInit', '33559295', '4926' ]);
</script>
</body>
</html>
